0 votes
by (120 points)
Ok. I have got music in the background of my twine game on my starting passage. When I press a passage link it stops. Is there anyway to make it continue playing. It is a 24 minute song and is supposed to play throughout the whole game. Here is what I have got so far:

<audio src= "https://www.dropbox.com/s/tv7ir0r4uzpa6wi/Music.mp3?dl=1" autoplay>

1 Answer

+1 vote
by (144k points)

Searching this site for "background music" lead me to How do you add background music?

by (120 points)
Yeah that code didn't work for me and it was incredibly long. It also bugged out a lot. Thank you for your concern.
by (61.3k points)
If you have the time, pease open an issue on the repo to report bugs so I can fix them. I tested on the most recent version of Harlowe, which is 2.1.0, not 2.1.3 (which sounds like a Twine version, not a Harlowe version, btw), as listed in your tags. If you're using Harlowe 1.x that code may not work.

You can check the story format version from the change story format menu item in the up arrow menu on the bottom left of the screen, near your story's title.

There isn't much I can do about the code being long, it does a lot of things.
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...