+1 vote
asked by (710 points)

SugarCube – v2.23.4

While I could solve the problem with this code in the script passage

Config.passages.start = "Start";

The build version show the Debug Mode.

http://i63.tinypic.com/2zh19p5.png

How did that happen? Is it because I had attempted to port my story in Twine 2, failed pretty hard, then I uninstalled Twine 2 afterward? I did remove the appdata too.

1 Answer

+1 vote
answered by (115k points)

I downloaded the Twine 1 release of SugarCube v2.23.4 then tested it in a new Story Project and received the same 'Starting passage ("") not found' error. It appears the issue is in that release of SUgarCube 2.x and not your project.

I suggest you create a new issue on the story format's repository so that it's developer learns about the issue and can then fix it.

commented by (55.4k points)

The issue is already known.  An update to one of the components of SugarCube's build system—specifically UglifyJS—caused the issue.  A workaround has been implemented, but not yet released.  It will be in next release, which should be soonish.

commented by (115k points)
Thank you for the information.
commented by (710 points)
edited by

Thanks. In the meantime, I can still work with this...

Config.passages.start = "Start";

...but how to hide the new debug window, at the bottom of the screen? It still shows up even after the story in build. 

If it's not possible, where can I get a previous version of SugarCube? I'm on a Steam app update (with new translations) and I cannot wait for too long. indecision  

EDIT: Found out how. With this: 

Config.debug = false;

 

Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...