0 votes
by (240 points)

Hi,

I'm using Harlowe 2.0.1.

I've made a twine story. I have a folder like 'MyStory' and in that folder is the published html file and all the images it references.

When I open the html file on my computer, it works fine and I can see all the images in the right places.

However I made a copy of this folder on my mobile (Android), and when I open it (in Chrome app), all text/links etc work but the images don't show, just a little white icon and the alt text.

I tried putting it all inside a zip file because I saw that somewhere, but it didn't help.

It's just a private story so I don't want to publish it anywhere. I just want to be able to look at it on my mobile.

I think I am putting the images in correctly? I write (for example):

<img src="testimage.png" alt="photo of a man" align=left>

 

I'm don't understand Twine very much and my written English is terrible so sorry if I'm not making sense.

Thanks in advance!

1 Answer

+1 vote
by (62.7k points)
selected by
 
Best answer
Mobiles have tight security with things like file system access (think of the message you get when an app wants to access your device's pictures and such). I don't know of any way to get a local html page access to the file system on a mobile off hand. You can embed the images, or host them somewhere, though.
by (240 points)
Ah, OK, that makes sense. Thanks, I will probably try to host them somewhere. Not looking forward to going through the story and changing hundreds of images to hosted links!
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...