Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Macros appear in Play with Sugarcube Format?

Hi. Super new to Twine here. I've started experimenting with variables and I noticed that when you write them in Harlowe they won't show up in Play but when I switched to Sugarcube for some styling purposes they don't go away. Any ideas how to fix this?


  • An example of what you're trying would help.
  • I'm also new to Twine and also having the same problem.  In Twine 2.0 I turned on Sugarcube.  Then I copied this text (an example given in the Harlowe documentation) into a new passage:

    (set: $alive to $heartbeat > 0 and $breathing)

    You find yourself in a dark, $alive[spooky ]part of the dungeon.

    $alive[You sniff the air cautiously. Ghost odours abound.]

    When I test the story starting from that passage, it just prints the text back to screen verbatim, rather than run the script.  However, if I turn off Sugarcube and instead turn on the Harlowe format, the scripts work.  Do they only work in Harlowe format?
  • Each of the three story formats (Harlowe, Snowman2 and SugarCube) available for Twine 2 have their own macro languages.

    The SugarCube documentation can be found here.

    A similar example for SugarCube would look like the following:

    <<set $heartbeat to 1>><<set $breathing to true>>

    <<set $alive to $heartbeat > 0 and $breathing>>

    You find yourself in a dark<<if $alive>>, spooky<</if>> part of the dungeon.

    <<if $alive>>You sniff the air cautiously. Ghost odours abound.<</if>>
  • Thanks for your help!
Sign In or Register to comment.