Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Links not working!!

My first passage ends with a link but when I test the game it appears inside double brackets, as it does in the code, and isn't clickable. I'm making this game as a school project and it's due by the end of the week so I'd appreciate some help!


  • You need to state which Story Format you are using when you ask a question, as answers can be different for each one.

    The generic Twine 1 markup link should look something like one of the following, notice that there are no space characters before/after the Link Text or before/after the Target Passage Title.
    [[Link Text is the same as the Target Passage Title]]
    [[Link Text|Target Passage Title]]

    Could you supply an example of the markup link that does not work.
  • I'm using Sugarcube and my markup text looks like this:

    "<span class="choice">try to escape.</span>"
  • You didn't state which version (1.x or 2.x) of SugarCube you are using, so I tested your code example in both versions.
    I was also not sure if the the quotes surrounding your example were there to distinguish the example or if you want the generated link to be shown wrapped in quotes so I tested both.
    Please use the C button in the toolbar above the Comment field to wrap your code examples in code tags, it makes them easier to read.

    I tested the following using the latest release of both versions of SugarCube (1 and 2) in Chrome / Firefox / IE / Edge on Windows 10, and both links sent me to a passage titled try to escape. (notice the full stop on the end of the passage title, it needs to be in the passage's title because it is in the markup link)
    @ (notice the full stop at the end of the passage title!)
    with quotes: "<span class="choice">[[try to escape.]]</span>"
    without quotes: <span class="choice">[[try to escape.]]</span>
  • edited February 2016
    My story format says it is set to SugarCane it does not specify a version. My link is contained within one div and two spans, and has a border. I attached a screenshot of what my beginning passage looks like as of right now.
    Here's what the code looks like:
    <span class="last">You don't even know if you are still<span class="choice">[[alive.]]</span></span>

    My problem is that although "alive." is written between double brackets, it doesn't register as a link. In my storybuilder area a line is connecting the passages "Start" and "alive.", and I can edit the "alive." passage but the Start page of my game doesn't provide a link of any kind. It's just plain text that appears in double brackets tauntingly.
  • You originally stated you were using SugarCube, which is why I tested using it.

    This time I created a Story using Sugarcane with your latest example cut-n-pasted into the Start passage, and the link displayed correctly and worked as expected.

    It is difficult to debug a passage using only snippets of it's contents.

    Which operating system (brand, version, 32/64bit) and web-browser (brand, version) are you using?

    Could you try retitling the 'alive.' passage to be 'alive' (without the full stop) and changing the markup link to be the following and see if that works.
    <span class="last">You don't even know if you are still<span class="choice">[[alive.|alive]]</span></span>
    ... it is generally not a good idea to use punctuation/meta-characters in your passage titles, as it can cause issues.
  • I'm using the latest version of Google Chrome- although I tried to open it in Firefox and the same problem occurred. I'm also using a 64 bit operating system (Windows 8.1).

    I tried retitling the passage to "alive" instead of "alive." but to no avail.

    Links are broken in my other passages as well. They're recognized as outgoing and incoming links, but when I test the story they're still busted. Would it be more helpful if I pasted an entire passage here?
  • It would be helpful if you uploaded a copy of your story HTML file to a file hosting website (Dropbox, Google Drive, Mega, etc...) and either post the link in this thread or PM'ed me the link.
Sign In or Register to comment.