Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Twine win64 no longer functions: An error occurred during startup while initially synchronizing

I've been using Twine 2.1.1 just fine for a week, and then my PC happened to crash. Now, Twine will no longer function. When the program opens, it shows the following errors:

Message: Cannot set property 'id' of undefined
File: unknown
Line: unknown
Column: unknown
TypeError: Cannot set property 'id' of undefined at IMPORT_STORY (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:40:12189) at i.(anonymous function) (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:84:5845) at r.value (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:84:4841) at dispatch (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:84:4102) at importStory (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:9:14310) at chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:41:15776 at chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:41:15665 at Object.loadAll (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:41:15822) at chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:52:31866 at Object.init (chrome-extension://jbeclgngiacjdjjokiegbkjcpibcdcic/twine.js:53:101)

Twine will not show the Home screen, so I can't do any editing. I've tried to uninstall Twine and reinstall repeatedly, but I just always get this error.

Any help? Thanks,


  • edited March 2017
    I had a problem with Twine not fully uninstalling and gave me different problems. My solution might help you though. Uninstall Twine then delete the Twine folder in C:\Users\yourusername\appdata\Local
    After doing so, my problem was solved. That folder has a lot of critical data in it and I would be willing to bet that you'll have success when you re-install Twine.
  • The following instructions explain a more direct way to locate the folder which needs to be deleted, because depending on your Windows configuration the appdata-local folder may be located elsewhere.
    entering %LocalAppData% in explorer or run (WIN+R) will take you there. Once there, find the Twine directory and delete it, along with its contents.
  • edited March 2017
    My apologies.
  • Keening wrote: »
    My apologies.
    There is nothing to apologise for because your answer is correct and would work for most users of recent versions of Windows, and I'm sure the OP and other forum visitors appreciated your quick reply.

    I was just expanding on your correct answer for those that may be either using a different Windows configuration or a slightly older version of Windows.
  • Thank you
  • Thanks, but still no luck. I deleted the Local App Data directory and reinstalled with the same issue. So, I uninstalled again, and did a search for "Twine" anywhere on my C: drive. I deleted all of those and reinstalled, and got the same result. Perplexed and frustrated.
  • Did you try a system restore to a previous date?
  • OK, I almost went there, but I sort of followed through on your earlier advice and went into RegEdit and deleted all references to Twine. That did the trick. It is working properly again.

    Thanks, Keening and greyelf for the suggestions!
Sign In or Register to comment.