Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Online version 2.1.3 - I cannot "Publish to file" from a specific story

I am able to publish to file on other stories I have created still but a particular story does nothing when I click "Publish to file". It does nothing from choosing that option in the story itself, nor from the setting option on the main page where it says "5 stories":!/stories

At the moment my story is a work in progress with some disconnected elements. Would this stop me from being able to publish it as a story? If so, does anyone know of a way for me to be able to share the story in its current state with a collaborator?

Thanks in advance!


  • I tried to connect everything to see if that was the issue but I still am unable to "Publish to File" so I would love some help with this! :smile:
  • I have this problem as well. Help would be much appreciated! Thanks!
  • I am not about to reproduce this issue but two possible things I would check are:

    1. You have one of the Passage's in that story marked as the starting point, this can be done using the 'Rocket Ship' icon on the Passage's context menu.

    2. You have a Story Format selected for that story.
    Use the main menu in the Passage Map to access the Change Story Format option to open the Story Format dialog, first select a Story Format you don't want to use, then select the Story Format you do want to use, that should make sure the story has the correct Story Format associated with it.

    P.S. Do you have any code in the story's Story Javascript area?
  • I do not have anything in the JavaScript area, and I have a starting point and am using Sugarcube. Thanks for responding!
  • and am using Sugarcube.
    Did you do the select different Story Format then the one you actually want process I described?

    If you update the version of Twine 2 you are using and that new version includes new versions of any Story Formats then the application will automatically update your existing stories to use the latest version of the relevant story format, if this fails you can be left with a story referencing a non-existing story format which could result in the issue you are seeing.
  • That worked for me. Thanks, and sorry for misunderstanding!
  • It was as simple as not having a rocket ship to indicate the starting point of the story. Thank you very much for your help, I will definitely remember this advice should this happen again!
Sign In or Register to comment.