Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issue Converting from Harlowe 1.2.4 to Harlowe 2.0.1


I have a simple but frustrating problem. I really like to use underscores in my passage names (for example, "introduction_1"), and this works just fine in Harlowe 1.2.4. I am trying to convert over to 2.0.1, but doing so makes Twine think all my references to passages are clumped temporary variables.

(So if I reference that passage, "introduction_1" in a (goto:) macro, it thinks I am trying to reference a temp variable called "_1" which I guess just resolves to null.

Do I have to go through my whole story and add little apostrophes before every single underscore? Or is there an easier way to avoid this problem?



  • Are you placing the passage name in quotes? Anytime you give a passage name as an argument, you should generally quote it, since things can get dicey otherwise.

    I tried it in 2.0.1 and things worked fine when quoted.
    (goto: 'introduction_1')
  • Hmm, I've been using double quotes, but will try single quotes!
Sign In or Register to comment.