Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problems building a story

edited February 2015 in Help! with 1.x
I had a hard drive fail and used a backup, but when I open my .TWS file and try to Test / Build I get an error.

Traceback (most recent call last):
File "storyframe.pyo", line 907, in rebuild
File "tiddlywiki.pyo", line 143, in toHTML
NameError: global name 'noDefaultCSS' is not defined

I think it has something to do with file paths, as the .TWS was originally on a different drive letter and location.

If I import the .TWS or even if I import a compiled HTML version of the story I get the same errors.

Is there anyway to get around this or do I have to start it from scratch and copy / paste hundreds of passages?

Windows 7 / 64bit, Twine 1.4.2


  • Are you able to upload a copy of your TWS so it can be used to debug the problem?

    Which version of Twine did you originally use to create the TWS file?
  • I have attached three TWS files all giving the same error. The actual story TWS is too large to attach, but these all have the same error.

    I'm not sure of the version, it would have been the current version last Feb / March (2014) as that was when I began work on the story.
  • A bug was introduced to Twine as part of the Story Metadata update, unfortunately it was not discovered and fixed until after Twine 1.4.2 was released.

    The bug only occurs if both the "Include the jQuery script library" and "Include the Modernizr script library" options are selected in your story's StorySettings passage, by default both are unselected.

    Un-selecting either one of these options will allow you to build your HTML file.
Sign In or Register to comment.