Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can I stop Twine 2 from automatically creating passages?


Twine 2 has the unfortunate habit of spawning a load of passages for me that are completely unusable. I use Sugarcube and tend to change variables a lot inside passages:

As soon as I've finished editing a passage with those kinds of links Twine 2 will spawn a passage named "ExamplePassage][Variable += 10, OtherVariable--" or some such. I can remove it and it doesn't come back, but next time I change something inside the link (for example, Variable += 9) it'll once again automatically create a new passage named "ExamplePassage][Variable += 9, OtherVariable--".

It's starting to get real irritating, especially when I change a lot of things at once the new (dummy) passages just start overlapping my actual passages and I have to spend some time fishing them out.

In Twine 1it used to ask if I wanted to spawn empty passages, and that was fine. Twine 2 does it automatically.

Can I disable this behaviour?


  • edited October 2015
    Currently there is no Twine 2 option to disable the Auto Create Passage feature, although their has been talk about this issue on the Twinejs project site. The next release of Twine 2 should be including better support for SugarCube's Setter markup links.

    I believe you can however get around it in the short term by using SugarCube's <<click>> macro instead of a Setter markup link:
    <<click "This is an example." "ExamplePassage">>
    	<<set $Variable += 10>>
    	<<set $OtherVariable-->>
  • Thanks for the answer! Much appreciated.
Sign In or Register to comment.