Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Not working on my Win10

I am trying to open Twine 2.0.10 after installing it on my Windows 10, but after installation it won't open. A half a second of loading circle and nothing more. What's the problem? Both Twine 1 and 2 are not working.


  • edited December 2015
    Can you look in Window 10's Event Viewer and see if there were any error messages in either the Windows Logs > Application section or the Windows Logs > System section.

    Which edition of Windows 10 do you have?
  • I have Win10 Home version. When I open Twine in default, there's no message, but after opening it as admin I'm getting DistributedCOM error no. 10016.
  • In your Windows Event Viewer that error should also include a text message, with a format something like the following:
    The %1 permission settings do not grant %2 %3 permission for the COM Server application with CLSID %4 to the user %5\%6 SID (%7). This security permission can be modified using the Component Services administrative tool.
    ... where the %1, %2, %3, %4, %5, %6, and %7 tokens will be replaced with text relevant to your error.

    Could you supply the related error message text, as this may help the developers determine which (Administrator?) Permissions** the application requires that it does not have access to already.

    (** Although I am a little surprised that the Twine application requires any Administrator Permissions to run in the first place)
  • I'm from Poland so I'll post this in Polish, I think you will know what is what.

    Zgodnie z ustawieniami uprawnienia domyślne ustawienia komputera nie jest udzielane uprawnienie Lokalny Aktywacja do aplikacji serwera COM z identyfikatorem klasy CLSID
    i identyfikatorem aplikacji APPID
    użytkownikowi ARTUR-KOMPUTER\Arthur o identyfikatorze zabezpieczeń SID (S-1-5-21-54086640-4156003469-1001455168-1000) z adresu LocalHost (użycie LRPC) działającemu w kontenerze aplikacji o identyfikatorze SID Microsoft.Windows.Cortana_1.6.1.52_neutral_neutral_cw5n1h2txyewy (S-1-15-2-1861897761-1695161497-2927542615-642690995-327840285-2659745135-2630312742). To uprawnienie zabezpieczeń można modyfikować przy użyciu narzędzia administracyjnego Usługi składowe.
  • After trying to open it compatibility mode with Win7 I have at 4 processess and Twine is still not shown.
  • The Google Polish to English translation of the original error message is:
    According to the settings, the default permissions settings on your computer is not granted permission to Local Activation server application COM class ID CLSID
    { C2F03A33-21F5-47FA - B4BB - 156362A2F239 }
    and application identifier APPID
    { 316CDED5 - E4AE - 4B15-9113-7055D84DCC97 }
    user ARTUR - COMPUTER \ Arthur security identifier (SID S - 1-5-21-54086640-4156003469-1001455168-1000 ) from localhost (using LRPC ) acting in a container applications SID Microsoft.Windows.Cortana_1.6.1.52_neutral_neutral_cw5n1h2txyewy (S- 1-15-2-1861897761-1695161497-2927542615-642690995-327840285-2659745135-2630312742 ) . This security permission can be modified using the Component Services administrative tool.
  • And it still doesn't mean anything to me.
  • KingArchee wrote: »
    And it still doesn't mean anything to me.
    That message was not for you, it is for the Twine Developers.

    It should help them determine what permissions/rights are missing and what changes are needed to allow the application to work correctly on Windows 10 Home edition, which by default has a more restrictive set of permissions.

    I suggest you create a new issue on the Twine project website, explaining what happen (or didn't happen), which edition of Windows, and include a copy of both the Polish and English translations of the error message text.
  • Okay, thank you very much for your help. I'll make new thread ASAP.
Sign In or Register to comment.