Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Stories are Blank

Hi, I just started using Twine 2. Every time I Publish to File, the resulting story appears blank when I open it in Chrome or Safari (on Mac). The actual HTML appears to be intact, but nothing shows up in the browser. I've tried both the desktop and browser versions of Twine, and I have no problem playing the projects in Twine itself.

Does anyone know how I can get these stories to work on their own?


  • edited April 2017
    If you're opening the files within the Twine's Stories directory, those are the individual story project archives, not the compiled/published story. By default, there is nothing within Twine's directory that you should normally be poking manually. If you are publishing to that directory, then you should stop or you could damage your projects.

    It's likely that your browser is saving to its default download directory, so you should be looking there for the compiled/published files.
  • Thanks for the reply. I'm publishing to the desktop and staying away from Twine's directory, but the stories still won't open. Here's a test story if you'd like to see what I mean.
  • For some reason the above file works when it's hosted on this website, but it won't work if it's saved on my machine. Any idea why this is?

    If I download it and open it from my desktop, it comes up blank again.
  • Huh. No idea. It works for me—in both Firefox and Chrome on Windows.
  • edited April 2017
    Did you import the story file into Twine 2? I've had it publish blank files because imported stories appeared to have no story format defined. After selecting a format with "change story format" it worked.

    Bunch of publishing bugs with Twine 2 on OS X... the main "publish to file" is unresponsive, and duplicated story will not publish or save... just disappears after relaunch.
  • edited April 2017
    I've created stories within Twine 2 for Mac and Twine 2 for web and each gave me the same result. I also tried changing the story format to Harlowe 2, then back to Harlowe 1.2.3.

    It seems that the HTML story file will play when hosted online, but it won't play if I store the file locally. I wish I could figure out why.
Sign In or Register to comment.