+1 vote
by (370 points)

I'm using Twine 2.1.3 and Harlowe 2.0.1 and for some reason the prompt doesn't appear. Instead there is an error that says '1 too many values were given to this (prompt:) macro.' and the code I used was from the Harlowe 2.0.1 manual. It doesn't work with the online or offline version of Twine on my laptop.

Here is the code:

(set: $name to (prompt: "Your name, please:", "Frances Spayne"))

 

3 Answers

+1 vote
by (410 points)
This must be a current bug with Twine 2.1.3, surely. I just used it in my version of Twine (2.1.1) and it works without any problems.
+1 vote
by (2.2k points)
I've seen this error as well, just after having it work too. You could try deleting the second value , running it, and then re-adding it when it tells you that doesn't work too. That's how I managed to get it work, though it's not an actual solution.
+1 vote
by (153k points)
That error should only be displayed if you are using Harlowe 1.x, are you sure you have Harlowe 2.x selected as your story format?

I just tested your code example in both the web-browser (in Chrome) and the install-able release of Twine v2.1.3 on Windows. with Harlowe v2.0.1 selected as the story format and it work correctly in both.
by (370 points)
Oh my gosh! You were right greyelf! For some reason I set the Story Format to Harlowe 1! Thank you for reminding me ! Sorry everyone! Thank you for trying to help!
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...