0 votes
asked by (180 points)
For some reason Twine 2.2.1 crashes on my Win10. I also have Twine 1.4.2 it runs fine.

When I start Twine 2 it comes up with the window, but after 2-3 seconds of loading and nothing shown yet in the window it just close the main window and nothing more happens.

In the Task Manager it shows and then closes.

I have tried the 64 bit version as well as the 32 bit version.

So what to do to fix this?

//LarsPM

1 Answer

0 votes
answered by (26.7k points)
The most common cause of this problem is a corrupt "User Data" directory.

To fix this, open Windows Explorer (not to be confused with Internet Explorer), then navigate to "C:\Users\(your user name)\AppData\Local\Twine" and there should be a "User Data" directory there.  Rename the "User Data" directory to anything and then try opening Twine again.  If that works, then just delete that renamed directory.

If that doesn't work, we're going to need more details, but usually that does the trick.

Hope that helps!  :-)
commented by (180 points)
It helped. Worked like a charm.

I think my flaw was to install an older version of Twine after I had installed Twine2.

Now it works.

//LarsPM
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...