0 votes
by (120 points)
Hey,
Is there any way to exclude comma from link?
img: https://imgur.com/a/FPvaet4

As you can see, comma is blue - active. How to exclude this sign?

Thanks in advance!

1 Answer

0 votes
by (154k points)

As a general recommendation you should not include puntuation characters in Passage Names. I would suggest using the following Markup based Link variation whenever you need such characters in the Link Text, and to exclude those characters from the Target Passage Name.

[[Link Text->Target Passage Name]]


What your are seeing is a limitation of Harlowe's syntax highlighter when it comes to recognizing the contents of a Markup based Link that contains a coma, and switching to the above recommendation will not resolve this limitation.

You could replace that specific Markup based Link with a (link-goto:) macro based one, however that will remove the associated connection arrow in the Story Map.

(link-goto: "task, 1", "Target Passage Name")

 

Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...