0 votes
by (1.4k points)
edited by

Hello all!

SugarCube 2.28.2

It used to be that you added:

Config.saves.autosave = "thunderbirds";
Config.saves.autoload = true;

to your javascript, and it would save in passages tagged "thunderbirds". Recently it autosaves in every passage even if I delete these lines from the javascript. What changed and especially how do I make it stop?

Thank you!

[Update: I think this problem is with reloading the tab: closing and reopening seems to work normally. But if I reload the tab it goes to the passage you are on, but of course since the background sound is started on a previous passage it is lost.]

1 Answer

0 votes
by (67.8k points)
selected by
Best answer
The current play session being restored if a player reloads the page has always been a feature of SugarCube (since v1), it is nothing new.

Using SugarCube's restart feature or closing out the tab/window will drop the session.
by (1.4k points)
I guess I had always closed instead of reloading the tab before, or got confused with some other problem. Thanks anyway!
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.