0 votes
by (190 points)
edited by

So last night i made some big progress on my sugarcube story, today i launched it only to find that my story has  been reset to its previous state,erasing all my work. I tried googling it, but it came up empty, apart from one search from last year who had the same issue but was asking how to change the directory of the "stories" folder ( http://twinery.org/questions/3668/modyfying-library-twine-stories-folder-location) theres a link in there taht say's its a know issue, but when i click on it, it says:

This repository has been deleted

Our apologies, but the repository "klembot/twinejs" has been deleted.

It now lives at https://github.com/klembot/twinejs.

Following the github to the issues and finding the article, it talks about the russian locale, and i am not having the memory issue. I am using the english locale, how can i fix this?

I have a second issue where it keeps duplicating my story whener i go to the homescreen, which messes with my ocd.

edit: Appearanttly a first issue, relating to the second, popped up. Whenevrr i  click play or bugtest it just opens a nonresponding white window.

edit2: While i am still not having the memory issue, but it is creating multiple twine processes in task manager, however after the 4th process the above issue was fixed? sorry if this should be posted elsewhere, i am new to twine so i have no idea where to report al lthis and get fixs.

edit3: i tried loading the new version of my story(archved it before closing application to reboot) and it just removed my story. my old version, however did work.

edit4: tried using the webbrowser version, and it is not making duplictes, or removing my story, but it is still not letting me play it. Just brings up an empty window. Reinstalling did nothing.

2 Answers

0 votes
by (159k points)

Whenevrr i  click play or bugtest it just opens a non-responding white window

This generally indicates that the story doesn't have a story format selected, or that the version of the one it thinks is selected isn't there. This issue can generally be fixed by either:

a. Using the Change Story Format option to select the story format you want, in the case where no story formal is selected.

b. Using the Change Story Format option to first select a story format you don't want to use and then selecting the one you do want to use, in the case where it seem like a story format is already selected. You may need to exit and then reopen the Story Format dialog between selecting the one you don't want and then the one you do.

 to find that my story has  been reset to its previous state

 You didn't state is you are using one of the web-browser based releases of the Twine 2.x application or if you are using one of the install-able releases, nor did you state which operating system (name and version) you are using or (and in the case you're using a web-browser release) which web-browser (name and version) your using.

If you used the Publish to File option to create a story HTML file containing the lost version of your story then you should be able to use that file and the Import from File option to recover the lost content. The same is possible true if you used the Archive option to backup your story projects.

by (190 points)
I tried changng the story formats just now, including chnging it, rebooting the game then changing it to the one i want, and it is still only bringing up the empty white screen. And i am using the most currentof the installable client(even tried reinstalling)on windows 10. i then tried it on the browser (firefox) and that didnt work either. (see edit4) Just tried changing the story formating the browser version as well and didnt work either. I dont know the versions of windowws 10 and firefox im using, but theyre the most current one. It worked fine last night.
by (190 points)
I started a new story and just copied all me stuff over, it works for now, the new story that is. but the old ones still don't. It seems it also saved it and did not duplicate it.
by (159k points)

The install-able releases and the web-browser releases store the Story Projects in different locations so you can't automatically access projects created in one release type within the other release type. You would have to use the Archive option in one release type and then import that archive HTML file into the other release type.

The same is true between the different brands of web-browser. A Story Project created in one brand is not automatically available within a different brand because each brand uses a different location (and possible format) to store it's Local Storage content. Again you would need to use the Archive option.

by (190 points)
Yeah i added them back into twine (both client and browser) via the archive, it still caused them to bug out.
0 votes
by (44.7k points)
It sounds like the Twine user data got corrupted.  Make sure you have backups of everything and Twine is closed, then rename your "C:\Users\YourUserName\AppData\Local\Twine\User Data" folder to something else.  Now try opening Twine to see if that fixed the problem.  If it did, then you can delete the renamed "User Data" folder.
by (190 points)
Nope, did not work.