0 votes
asked by (120 points)

In Harlowe 2.1.0,

(link: "Austin Kleon on musicianship and gardening")[(goto-url: 'http://austinkleon.com/2018/04/25/the-gardens-where-ideas-grow')]

gives me a link which looks ok but when I click it, I get

Failed to execute 'assign' on 'Location': 1 argument required, but only 0 present.

I'm guessing I'm being dumb, but I ran it past a couple of other people and we couldn't see what I'm doing wrong. If I put open-url, that works ok.

I took my guidance from this previous Twinery Q&A.

1 Answer

+1 vote
answered by (139k points)
I tested the example you supplied using Harlowe v2.1.0 in both the web-browser based release and the desktop application based release of the Twine 2.x application, and it worked correctly for the Test / Play / Publish to File options.

However I did get the same error message if I tried to use your example with the Harlowe v1.2.4 story format, are you sure you have Harlowe v2.1.0 selected for your Story Project?
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...