0 votes
by (120 points)
I'm in Twine 2 using Sugarcube 2 and I'm really struggling to change one word to bold in a passage. As simple as that sounds I can't seem to make/find any html or css codes that will work. I've never had this problem in the past when using things like Caret and Text. Would appreciate any help! Thanks!

1 Answer

+2 votes
by (62.7k points)
edited by

You can use SugarCube's markup

Blah blah ''bold'' blah blah. 

Or html. 

Blah blah <strong>bold</strong> blah blah.

/% or %/

Blah blah <b>bold</b> blah blah.

/% or %/

Blah blah <span style="font-weight:bold;">bold</span> blah blah.

Or custom style markup

Blah blah @@font-weight:bold;bold@@ blah blah.

Or some combination of html or custom style markup and CSS. 

Blah blah @@.bold;bold@@ blah blah.

/% or %/

Blah blah <span class="bold">bold</span> blah blah.
/* in stylesheet */
.bold { font-weight: bold; }

The first solution is probably the simplest, and is my recommendation. 

by (120 points)
Thanks for your help I'm sure this would work but I'm still struggling to embed it into Twine. The word I want to change is girthy.  Should it be in the body section? Do I need to give the word an id? Am I missing a trick or overlooking something lol. This is how it looks so far:

body {
  background-color:     #E0FFFF;
  font-family: courier new;
  color: #FF69B4;
  border:#ADFF2F;
  "girthy"
}
 

Once again thank you for you're help thus far!
by (62.7k points)
edited by
  1. Open a passage that contains the word you want to make bold. 
  2. Find the word. On each side, place two single quotes. So if the word is girthy, it should become ''girthy''. Note that these again are two single quotes on each side, not double quotes
  3. Close the passage and play it. The word should be bold now. 

Here's a link that describes SugarCube's formatting markup: 

http://www.motoslave.net/sugarcube/2/docs/markup.html#basic-formatting

I also linked this above. Markup goes in the passage itself, not in the stylesheet, though I can understand how you might think that. 

by (120 points)
This seems to have done the trick when I've made a new passage however I cannot seem to edit this in to my pre-existing story. It creates a new strand as opposed to changing it to bold and appears in the test mode as having the '' either side of the word.

Is there any reason as to why this happens and why my word still isn't bold unless I create a new passage?
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...