Why won't my images load in browser but the rest of the game works?

0 votes
asked Jan 3 by jaymajaym (130 points)
I've been trying to upload my game to itch.io for awhile now, and everything is working except for the pictures. I've checked my code and it seems to be fine. Also I don't know if this effects anything but I've been using png files.

2 Answers

+1 vote
answered Jan 3 by Chapel (43,170 points)
Please provide code examples. We aren't psychic.
+1 vote
answered Jan 3 by greyelf (76,170 points)
edited Jan 3 by greyelf

1. Did you use relative URLs within your story's passage to reference the images?

eg. If your images are stored within a media sub-folder then the URL of your img element should look like the following.

<img src="media/image-name.png">

2. File and Folder names on that website (and most others) are case-sensitive, did you make sure not to use mix-case letters nor space or special characters in their names? It is OK to use a standard dash or an underscore in place of space characters.

3. Did you use the ZIP File method mention on the Uploading HTML5 games web-page to upload your Twine based story to their site?

4. Did you include the images used by your story within the ZIP file, and are those images within the correct sub-folder within that ZIP file?

index.html
media/john.png
media/jane.png

note: Obviously both the Folder(s) containing your images and the Images contain within them may have names different than my examples.

Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...