+1 vote
by (130 points)
edited by

Using Harlowe 2.0.1, the online version of twine. I'm trying to change the font to Google Font's Work Sans but it always defaults to Georgia. I've checked the twine wiki and a couple other sites that were probably outdated for help, but none of the suggestions worked. Some other bits of code I tried I've commented out.

@import 'https://fonts.googleapis.com/css?family=Work+Sans'
/*@import url('https://fonts.googleapis.com/css?family=Work+Sans')*/
  
tw-story {
  	font-family: 'Work Sans', Georgia, sans-serif;
    /*font: 100% 'Work Sans', Georgia, sans-serif;*/
}

tw-passage{
    font-family: 'Work Sans', Georgia, sans-serif;
}

It's probably a simple fix, but I don't know what's missing.

--

Edit: Fixed! Though I'm not sure why. I switched to Snowman, and the google font appeared, and when I switched back to Harlowe, the font stayed. I tried changing the ' to " and using the commented out "@import url('https://fonts.googleapis.com/css?family=Work+Sans')" instead and all those work. "font:" doesn't seem to work though, while "font-family:" does. 

1 Answer

0 votes
by (6.2k points)
Well done on fixing it, but its kinda annoying to keep seeing this when I click on 'Unanwsered' to see if I can help anyone. Would it be OK for you to accept this comment as an answer so that this shows up as answered?
by (8.5k points)
The default and expected behaviour for the StackExchange network, at least, is to write an answer yourself if you found a solution and mark it as accepted.
by (6.2k points)
Oh, sorry, I didn't know you could do that.
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...