0 votes
by (1.3k points)

Hi again,

I'm having some trouble with my (replace:)s. In some instances, they are working just fine. In others, they seem to be eating up a space here and there. Let me give an example. In my header-tagged passage, I have this:

(replace: "important term ")[(link-replace: "important term ")[explanation of important term ] ]

Sometimes this works beautifully! But sometimes I get output like this:

What I want:

You must understand this important term.

What I get:

You must understand thisimportant term.

I have quite a few (if:) macros happening in the header. Could this be affecting how the passage is rendered? Any other ideas? 

1 Answer

0 votes
by (62.7k points)
It's probably not the header. Can you show us the surrounding passage content / code. I'm having a little trouble figuring out exactly how the example here fits in.
by (1.3k points)
I think I fixed it. The code is really long and specific, but basically I think I was repeating the macro (that is, several instances of a macro targetted the same words) and the repetition caused the spaces to get eaten... I seem to have solved it, though. Thank you!
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...