Space between paragraphs with Harlowe 2

0 votes
asked Sep 9 by martinfr (160 points)
Hi everyone,

I've been trying to indent my paragraphs with <p> tags, and while I succeeded in doing so, now I have a new problem. When I play my story, there's a pretty big space betwwen my <p> tagged paragraphs.

I tried defining margin and padding as 0 in the CSS sheet, but it didn't work.

Any help will be thanked a lot!

PD: also, paragraphs not tagged with <p> appear with variable spaces between them when played on Mozilla, but that may be a problem specific to that browser.

1 Answer

+2 votes
answered Sep 9 by greyelf (37,190 points)

Are you using markup to escape the line-breaks between your paragraphs? If not then they can cause unwanted spacing between them.

<p>Contents of the first paragraph...</p>\
<p>Contents of the second paragraph...</p>\
<p>Contents of the third paragraph...</p>

By default a HTML Paragraph element has a top and bottom margin, you can use the CSS within your story's Story Stylesheet area to change the default values of the related margin-top property and margin-bottom property like so.

p {
    margin-top: 0;
	margin-bottom: 0;
}

 

commented Sep 13 by martinfr (160 points)
That worked perfectly. I didn't know about line breaks in Harlowe, and I thought that setting a general margin to 0 would be enough.

Thank you so much for your help! That was driving me crazy.
Welcome to Twine Q&A, where you can ask questions and receive answers from other members of the community.

You can also find hints and information on Twine on the official wiki and the old forums archive.

See a spam question? Flag it instead of downvoting. A question flagged enough times will automatically be hidden while moderators review it.
...